Commit a1ed9204 authored by Laurent Bachelier's avatar Laurent Bachelier

Add another way to check for Pillow

parent e3bf6fa5
......@@ -12,10 +12,11 @@ try:
except ImportError:
PIL = 'Pillow'
else:
if 'PILcompat' not in Image.__file__:
PIL = 'PIL'
else:
# detect Pillow-only feature, or weird Debian stuff
if hasattr(Image, 'alpha_composite') or 'PILcompat' in Image.__file__:
PIL = 'Pillow'
else:
PIL = 'PIL'
REQUIREMENTS = [PIL, 'mako', 'webob', 'paste', 'PyRSS2Gen', 'python-dateutil']
if version_info < (2, 7):
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment