Commit e3bf6fa5 authored by Laurent Bachelier's avatar Laurent Bachelier

Work around Debian compatibility layer

parent a83d565e
......@@ -6,11 +6,17 @@ from sys import version_info
assert version_info >= (2, 6)
DATA_DIR = 'share/assnet'
PIL = 'PIL'
try:
import Image # NOQA
import Image
except ImportError:
PIL = 'Pillow'
else:
if 'PILcompat' not in Image.__file__:
PIL = 'PIL'
else:
PIL = 'Pillow'
REQUIREMENTS = [PIL, 'mako', 'webob', 'paste', 'PyRSS2Gen', 'python-dateutil']
if version_info < (2, 7):
REQUIREMENTS.append('argparse')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment